Olav Alexander Mjelde, Volvo 960 1995 "S90" - TwinTurbo soon

olavxxx
MegaSquirt Newbie
Posts: 1
Joined: Sun Sep 07, 2008 11:59 pm

Olav Alexander Mjelde, Volvo 960 1995 "S90" - TwinTurbo soon

Postby olavxxx » Mon Sep 08, 2008 12:19 am

Image
My "MSTronic" as it has been named, is a megasquirt fitted inside the Motronic 1.8 (Volvo 960) ECU.
The MSTronic was made for my Volvo 242, with controlling the TwinTurbo engine I have recently gotten completed.

Image
I however bought a new car, a Volvo 960 1995 (the new type, eg. "s90").
When I was going to venture the Megasquirt world, I looked at different megasquirt dealers and I found one that sells P&P kits for BMW (which also use the Motronic ECU, though a different model).

Image
I had some advantages:
* I knew about one guy with a similar engine which already uses MS, he also had a MSQ with most of the settings correct for my use (the poi @ turbobricks).

Image
So, yes.. I found this site: http://diyefi.co.uk
Stuart which runs the site agreed to help me with my P&P project for the Motronic 1.8.

I started by sending him different wiring-schemas and information about the engine.
Then we discussed for several days what hardware I want/need/should have ( I wanted to be sure I got it right the first time ).

Also he helped me to aqquire WBO2, WBO2 controller, IAT sensor, wiring parts+++.
Then I went on ebay.co.uk and I found a Volvo 960 ECU, which I then bought and got shipped to Stuart.

Stuart then used about a week or so (a bit less, actually) to then customize and test the MSTronic for me.
He even loaded it with "the poi"'s MSQ and the MSNS firmware.

The specs on my MS setup is:
* MS 3.57 SMD
* MSII board
* I/O Board modded for boost
* Ignitor board modded for looping I/O
* LC1 O2 Controller
* LSU WBO2 sensor
* GM IAT sensor

I also seperately bought:
* KnocksenseMS

Stuart was very helpfull and he gave me a good price, since he could not test it other than on the test bench.
After I got the parts, I didnt test it for a while (I dont have a garage, so I have to test in the street - a bit of a hassle). I also went on vacation ;)

Then one day, I was going to test it.. But, it blew fuses :(
Stuart thought it might be the spark which should be inverted and after trying this, it seems like he was correct.
After choosing inverted output, it would no longer blow fuses :)

Ps. before inverting, I tried not inverting but removing some of the COP wires..
(I run WS on the COP's, via bosch powerstages).

Anyhew.. I could now crank it and it would not blow a fuse...
But, no start :(

So, what was left to do? Well, I couldnt see in megatune that the engine was cranking.
I read about some Volvo 850 dude who had a "no start" issue, which he resolved with adjusting the R52 pot on the MS board.

I was kindof nervous before attempting this, since it's very hard to see where a pot like that has been, if you wish to revert. But I measured the OHM at the setting it had, so I could revert if needed.

However, I turned it all the way counter clockwise, as per. the megamanual.
I cranked it, and I could hear it almost started :) Also it said now it was cranking!!

YEY!

Now I thought: I should check that setting in the MSQ which I had been thinking about before..
eg. we all use different settings, or most do.. So I thought I had to activate something I had been thinking about earlier.

It was injector bank 2.

I guess "the poi" only uses one injector bank..
After enabling the bank 2, now it would run!!

So, yes.. My MSTronic runs!!
However, it dies if I dont press the accellerator.

But the reason for it dying I think is only the sensors I have yet to attatch to it.
Eg. Even though I run a P&P version, I dont use the stock AMM (will use the IAT). Also I dont use the stock O2 and I wont fit the WBO2 in the stock O2 position.

You might think: Why not?
Well, I want to be able to revert in like 2 minutes!

So, I will run the low res output from LC1 to the OEM harness, so I can use the LC1 with the motronic 1.8.
Then I will run the other output (high res) from the LC1 to the spark board which is modded for looping I/O.
The IAT (GM) will be fitted on two of the AMM wires.
Knock input is via motronic 55 plug, but it also goes out on the "loop I/O", so I can collect the knock_1 and knock_2 in the KnocksenseMS and then send it to the MSTronic :-)

When I tested my MS, I had not fitted:
* IAT
* O2
* Knock (since I had not fitted the DB25)

eg. my MSTronic was actually "blind", meaning it only knew the temperature of my engine, it didnt know O2, inlet air temp and no AMM used :P But it ran "rather good", eg. it would stumble some, but I think it will be good when I have fitted sensors and tuned it.

TODO:
* Fit sensors
* Check wiring for E-Fan
* ++

Here is me soldering the DB25
Image
I have there soldered: KnocksenseMS wires, wire for wbo2 input, wire for changing map (premium unleaded/e85)

Then it was attatched to the KnocksenseMS
Image

I also had to have a tune-pc :-)
Image

IT RUNS
Image

Here is my car
Image

I am at first testing MS on my N/A engine (b6254)
Image

After I get it to run good, I will start planning the twinturbo engine inside..
Ps. I already have the twinturbo engine in my 242, but I have given up the 242 chassis due to some rust, dents in chassis and bad paint..

My twinturbo engine:
Image

It is built on a 960 engine, with v70 low compression pistons.
Then it has the xc90t6 turbos, custom oil and water lines (made by www.vikeboe.com) and it has piano string in the headgasket (so it can handle more boost).

Return to “Volvo, Saab”

Who is online

Users browsing this forum: No registered users and 3 guests