89 Suzuki Sierra (Samurai)

Post Reply
User avatar
Metalfab_101
MegaSquirt Newbie
Posts: 1
Joined: Fri Mar 11, 2005 10:30 pm
Location: Qld, Australia

89 Suzuki Sierra (Samurai)

Post by Metalfab_101 » Mon Nov 12, 2007 4:48 pm

This has been in the works for a while, but it's finally running.

Vehicle: 1989 SJ50 Suzuki Sierra
ECU: MegaSquirt v2.2, with flyback board running MSnSE 029q
Engine: Suzuki G13

Running fuel only at the moment.

On the inlet side I am using a manifold from a 1.6 8v Vitara (Sidekick) which is a bolt on for the G13 head. Interestingly the ports on the Vitara manifold seem to be a lot closer in size than the stock manifold. The stock Fidle solenoid is also utilised.

Fuel is provided by an in-tank pump donated by an RX7. Stock fuel pump has been removed and replaced with a blocking plate.

Exhaust manifold is stock Sierra, and has a heated o2 sensor, donated from some import Nissan, screwed into it. The stock manifold has no port tapped for an o2 sensor, but the casting has a 'nub' for this purpose, and was drilled and tapped to suit.

I have it wired using the B&G relay board. Home made cable between the MS and relay board, with the ECU mounted on the firewall under the dash.

For setup i cheated :twisted: and used the MSQ that Mad Max posted up here. It started and drove quite OK with these settings, and I have not played with them much yet. So far I have found that my TPS calibration didn't stick, but since sorting that it runs quite nicely. It needs a little work on accel enrichment off idle (bogs down when you flatten it) but other than that is OK.

IAT sensor

Image

Image

Exhaust manifold

Image

Image

kkelleynv
MegaSquirt Newbie
Posts: 3
Joined: Wed Nov 14, 2007 3:42 am

tuning

Post by kkelleynv » Wed Nov 14, 2007 3:49 am

I have a stock normally aspirated 96-98 1600 16V w/ MFI and Ignition running MSII V3, in my 87 Samurai. I'm just starting to tune. Any numbers you might have for a starting point would be a big help and greatly appreciated.

Thank you

Post Reply