1999 Subaru Legacy GT w/ JDM Turbo EJ20G & MS3/X

bmw5002
MegaSquirt Newbie
Posts: 7
Joined: Mon Jul 19, 2010 6:38 pm

Re: 1999 Subaru Legacy GT w/ JDM Turbo EJ20G & MS3/X

Post by bmw5002 » Sat Jun 04, 2011 5:49 am

Just wanted to update anyone Reading this thread: we have now gotten the car to run with almost no sync loss. Haven't done enough testing yet but so far the car has started within a second of cranking, and we can now rev an extra 1500 rpm up to 7000. This makes a huge difference in acceleration! Here's how we did it:
Used the jbperf vr conditioner board hooked to the cam and crank sensors
Put 12k inline and 2.2k shunt resistors on both cam and crank inputs just before they go into the vr conditioner board.
Turned on software noise filtering on the cam signal only.

It works! No pots to adjust - we just set them up for hall input and the vr board takes care of the adaptive control automatically.

I will post a screenshot of the noise filtering settings and a wiring diagram soon

tottestad
MegaSquirt Newbie
Posts: 2
Joined: Sat May 15, 2010 3:14 pm

Re: 1999 Subaru Legacy GT w/ JDM Turbo EJ20G & MS3/X

Post by tottestad » Sat Jun 25, 2011 11:14 am

Any chance you would look at my tune?
viewtopic.php?f=102&t=23105

bmw5002
MegaSquirt Newbie
Posts: 7
Joined: Mon Jul 19, 2010 6:38 pm

Re: 1999 Subaru Legacy GT w/ JDM Turbo EJ20G & MS3/X

Post by bmw5002 » Thu Oct 06, 2011 7:20 am

Another update: headgasket let go. After pulling the motor, we found that The intake cam with the cam sensor had jumped a tooth. The timing belt was also very loose. We pulled it off without releasing the tensioner. Seems that this may have been the cause of the sync loss all along. I'm not completely sure though because I know other users have had issues with the 6/7 pattern as well. But it's something to think about. I don't really want to pull out the jbperf vr conditioner board to test because it was running well with it. The lesson is to always check your timing belt and cam timing if you are having sync loss issues.

User avatar
a73camaro
MegaSquirt Newbie
Posts: 32
Joined: Fri Oct 08, 2004 5:44 am
Location: Dillon, CO

Re: 1999 Subaru Legacy GT w/ JDM Turbo EJ20G & MS3/X

Post by a73camaro » Fri Oct 07, 2011 8:00 am

Thanks for posting what you found. And you bring up a great point where a mechanical issue was causing your sync problems.

ryze
MegaSquirt Newbie
Posts: 1
Joined: Sun Dec 30, 2012 6:15 pm

Re: 1999 Subaru Legacy GT w/ JDM Turbo EJ20G & MS3/X

Post by ryze » Tue Jan 08, 2013 7:04 pm

Mind sharing your tune???

lgttobe
MegaSquirt Newbie
Posts: 1
Joined: Wed Jan 08, 2014 8:31 am

Re: 1999 Subaru Legacy GT w/ JDM Turbo EJ20G & MS3/X

Post by lgttobe » Wed Jan 08, 2014 9:07 am

I'd love to see your tune as well!
I suppose it may be adaptable to my requirements.

I'm really new to all of this. I've built an "EJ251D" (EJ25D Heads on an EJ251 Block with STi rods and pistons). I plan on running a TD05 set-up and my equipment will support 10 lbs of boost (and the hp that comes with it).

My concerns are:
-I must pass annual emissions testing...
Basically I plan on allowing the wastegate to open at it's lowest setting and just plug my stock ECU back in. (is this reasonable?)

- I need a little more clarification on my options for dealing with crank/cam sensors and coil/spark control. (as I understand it; Subarus require some special attention here?)

Any help or advice would be greatly appreciated!

Nick

User avatar
BoxerLove
MegaSquirt Newbie
Posts: 1
Joined: Tue Feb 09, 2016 8:06 am

Re: 1999 Subaru Legacy GT w/ JDM Turbo EJ20G & MS3/X

Post by BoxerLove » Tue Feb 09, 2016 8:16 am

REVIVE THIS!? :RTFM:

In the middle of building my swap now. Specs are as follows:

Block : EJ257 from 05 STI

Rods : Eagle 4340 H beam

Pistons : JE 2618 8.5:1 CR 99.5mm

Heads : V4 STI Heads

Intake : RA SPEC V LIMITED with 5th injector (What came off the heads, less concerned with the 5th injector as i want it running first)

Turbo : Rotated Garrett 60 Trim .60 A/R (I believe its actually a .63 A/R)

Management : MS3 (building it currently)


I believe you and I have the same idea for wiring. I wanted to make a harness using an old ej25D ECU plug which i already have cut off a spare ECU. Any more insight on this? My build is slowly coming together. Long block is almost finished. Wiring is really the only thing that concerns me, But there is always a way. Would also love a nice base map to start with if anyone has one and is willing to share :mrgreen:

Image

Post Reply