380SE - Running MS2 fuel - w126 1985

Mercedes.
harlz
MegaSquirt Newbie
Posts: 1
Joined: Tue Jan 12, 2010 4:31 pm

380SE - Running MS2 fuel - w126 1985

Postby harlz » Tue Jan 12, 2010 6:07 pm

Well, I guess I can post here in MSruns.com since the car drives! The car runs somewhat reliably, but is not tuned particularly well. It's been a lengthy project for me, but hopefully it will all come together when I have some more time soon.

Project Specifications;

Engine: Mercedes-Benz M116 3.8L V8
Injectors: 19lb bosch yellow top injectors x 8 ($120)
Megasquirt: MS2 DIY version, in black case, with the extended/advanced stimulator. ($500)
Spark setup: Standard distributor and coil, I have bought an EDIS-8 kit (ebay), but will wait until the fuel is well tuned first. ($100)
Fuel Rail: Aluminium fuel rail extrusion with brass push on connectors. ($250 rails, $250 connectors and hose) ($20 for junkyard fuel pressure reg)
02 sensor: Innovate LC-1 kit.($200)
Misc components: Hoses for idle air, washers, screws, etc ($150)
$ spent: About $1200
Time spent: A while!! (2 months off and on)

I had the fuel rails fabricated once I measured the injection spacing, I'll post up the diagram, then I went to Enzed, a hydraulics place, to get the fuel fittings. I had some trouble finding a FPR that would suit, I would recommend to integrate this into the fuel rail itself. I stripped off the k-jetronic system, leaving the injection ports open and inserted the injectors, then put the rails on. I drilled through the base of the rails and used an L shaped extrusion of aluminium with the injector mount positions drilled out. the L extrusion was bolted to the manifold and the rails. This wasn't the best way, but it worked :) I think it's best to get a fuel rail that has everything integrated ready to go.

Wiring took a while, but I wanted to take my time and and do it nicely, a tip would be not to make the run to complex, I had a lot of junctions. Not sure what the best material to wrap the wires in, but I used corrugated split tubing.
I also couldn't find any tps that would suit, so perhaps a new part will be bought for this, for now I'm going off the map for accel enrich.

I tuned tuned using both the manual cell changes and automatically the log analysis software, and I worked with Tuner Studio MS, rather than MegaTune for the most part. I think this project was a lot more frustrating than I initially thought, if you don't have a workshop and all the right tools it might not be the best idea. I'm having trouble getting the car tuned exactly, I feel like the 02 reading is off or there's some kind of problem with the engine or ignition system, unrelated to the old k-jet system, or perhaps the junkyard FPS I'm using. I guess more time and more money will sort it out. So far I can't say that I've had any improvements, the fuel economy is as bad as it was before or worse, and it's not as reliable since the idle air system won't allow for fast idle when cold etc. I think that MS will be great when I get it all sorted out, at least I hope I'll be able to have something to show for all my efforts!

Final thoughts so far: Can't say I'd be recommending the fuel component of MS for other 380SE engines, since the space is limited for rails, the 560 & 420 engines I believe has more room, the 300 is a single rail but if you do, make sure you get as much installed before you disable the car, 02 sensor, ECU, TPS, then you know what will be working and get an idea for ideal fuel ratios and you will be able to have 02 feedback as soon as you get everything hooked up. Fiddling with the engine advance made a big impact on idle speed, one of the only ways I can adjust it. I'm led to believe that you can get some good power gains from MS spark setup, if I can figure out how to get the toothed wheel and mount the pick-up onto the MASSIVE crank pulley, it sticks out of the engine's by about 30cm. Right now I feel a bit disappointed in the whole thing, but I'm also hopeful.

The things I got stuck on or that gave me grief...

Idle air setup - injector cups with idle air nozzles made the electronic injectors and thus fuel rail sit too high, linkages were in the way, so I couldn't use the injector cups. This meant the idle air had to come from somewhere else which is a REAL pain, currently, I have the throttle linkage opened partially when idle and no warm / idle control.

Fuel rails plus fittings were too large - Fuel rails also were too long and with the extra length of an adaptor from -8 size from the rail end to -6 of the elbow fitting for the fuel crossover, the original idle air screw assembly including warm up compensator will not fit. The oversize rail might have contributed to the above problem as well.

02 sensor setup - make sure you don't allow the sensor to disconnect from the controller while powered, or the calibration will reset and the values will be extremely wrong. This caused a big headache as I was trying in vain to wire it correctly, but it was the actual signal that was wrong. Make sure you get the 02 sensor installed while the car is drivable.

Finding a good tach input for MS - Don't go from the coil negative, this will cause the engine to have a seizure and not run, pick up the signal from the fuel pump relay connector, the green and yellow striped wire.

02 sensor delay time - while tuning, I got much better results when I analysed and entered the correct 02 sensor delay time. Use the MS viewer log software to see when an injector is pulsed over the normal value (push the accelerator) and then see how many milliseconds before the 02 sensor channel shows an reading.

Throttle position sensor (TPS) - nothing would fit. A new bosch unit might be small enough to fit.

icerobertcox
MegaSquirt Newbie
Posts: 1
Joined: Thu Jul 01, 2004 1:24 pm

Re: 380SE - Running MS2 fuel - w126 1985

Postby icerobertcox » Sun Jan 02, 2011 2:05 am

I am looking at installing a MS3 onto a 350sl merc.

I see you put in your MS about a year ago. Do you still have the MS running? Any updates would be helpfull for me.

Robert

Hey_Allen
MegaSquirt Newbie
Posts: 3
Joined: Thu Sep 27, 2007 8:45 am
Location: Washington, USA
Contact:

Re: 380SE - Running MS2 fuel - w126 1985

Postby Hey_Allen » Thu Mar 17, 2011 8:19 pm

It looks like the engine died and he's replacing it with a 5 liter engine, but with the stock management from what I can tell.

Take a look at the engine swap journal he's posting on BenzWorld.org: http://www.benzworld.org/forums/w126-s- ... -swap.html


Return to “Daimler-Benz”

Who is online

Users browsing this forum: No registered users and 1 guest