Holden HQ one tonne ute

Chevrolet, Pontiac, Buick, Oldsmobile, Cadillac, Saturn, Geo, Holden, Vauxhall, etc.
long283
MegaSquirt Newbie
Posts: 13
Joined: Fri Jun 02, 2006 6:01 pm
Location: Sydney, Australia

Holden HQ one tonne ute

Postby long283 » Wed Apr 16, 2008 12:13 am

Make: Holden
Model: 1973 HQ utility
Engine: 350ci Chev
Transmission: T350
Ignition: LS1 coil, Modified Chev distributor, Hall-effect sensor.
Injection: To be... Holley Pro-jection TBI
Bosch fuel pump
ECU: MegaSquirt 2 v3
Mods: Mild cam, flat-top pistons, ported heads, Edelbrock manifold,
Genie extractors, 2 1/2" dual exhaust.

The ute is not as pretty as the photo anymore. It's paint has faded and the body needs attention but the mechanicals are in excellent condition.

The distributor was modified to use a Hall-effect sensor, pull-to ground, goes open when the metal disk passes between the gap. A pull-up resistor is used from the 12v supply. Top bushing was replaced with a ball-bearing, vacuum advance was removed and the mechanical advance was locked in place by two screws.

The ECU is currently controlling the ignition and thermo-fan only.
I will be running 3/8" aluminium fuel line in and mounting the fuel-pump soon, before installing the TBI unit.

After a short time playing with the ignition map the engine has better response, better light throttle acceleration and no longer has any problems reving over 5000rpm. The ignition dwell begins to reduce over 4000rpm, being a single coil set-up but doesn't lose power ( yet ) and rarely gets to see those rpms when driven on the streets. The fuel delivery ( currently a Rochester Quadrajet ) is letting the combination down simply because it is too hard to find the right needles and jets for these in OZ but will hopefully be replaced by the TBI unit shortly... when I find time... Ok I'll make time then.
You do not have the required permissions to view the files attached to this post.

long283
MegaSquirt Newbie
Posts: 13
Joined: Fri Jun 02, 2006 6:01 pm
Location: Sydney, Australia

Re: Holden HQ one tonne ute

Postby long283 » Thu Apr 17, 2008 3:31 am

The engine had been running an electronic ignition kit from Jaycar for several years with no problems but I could never get the timing curve right when trialling different distributors, vacume advance and mechanical advances. The hall-effect sensor is p/n=ZD-1900 from Jaycar. The slotted disk was made on a milling machine using an indexing vice. I used relay plugs that allow the relays to be easily pulled for trouble-shooting or replacing. The TPS is plugged in at the moment but not mounted, it is just there to prevent a noisy signal to the ECU.
The fuse box seems to be cut out of the photo. It was at the bottom and is a 6 fuse unit from Narva. I didn't like the spade connections on it and preffered one I used on another project that had crimp connections at the back of the fuse-box.
There was plenty of room behind the dash to mount the MegaSquirt and the serial connector can be accessed through the center dash vent.
I have 3/8" aluminium fuel line and cushion clamps to run a supply line and will use the original 5/16" line as a return.

Thanks to everyone who made these DIY EFI projects possible and for all the information they have supplied.

More photos and details to come.
You do not have the required permissions to view the files attached to this post.

long283
MegaSquirt Newbie
Posts: 13
Joined: Fri Jun 02, 2006 6:01 pm
Location: Sydney, Australia

Re: Holden HQ one tonne ute

Postby long283 » Mon Jun 30, 2008 10:10 pm

Finally completed the EFI conversion.
Big thanks to Port Hacking Automotive for there help with installing the new 3/8" fuel line and surge tank.
The lift pump is outboard of the tank inside the fuel rail. The surge tank & high-press. pump are in front of the tank behind the cab.

With the wiring harness installed previously all I had to do was disconnect & block off the mechanical fuel-pump, re-route the fuel hoses, then unbolt the carburetor and installed the Holley ProJection unit. A 1" spacer was used so the built-in fuel press-regulator (at the back of the throttle body) will clear a manifold vacuum fitting. The accellerator cable bracket was changed to clear the air-cleaner base.
With the air filter installed it is hard to tell that it has been converted.

The engine fired up with the generated fuel map but will need some tuning and changes to the warm-up & accel. enrichment. before running. Ithink the Techedge wideband EGO will help with that.
You do not have the required permissions to view the files attached to this post.

long283
MegaSquirt Newbie
Posts: 13
Joined: Fri Jun 02, 2006 6:01 pm
Location: Sydney, Australia

Re: Holden HQ one tonne ute

Postby long283 » Mon Jun 30, 2008 10:12 pm

I will try to post the settings and maps when I have the tune sorted.
Hoping to get a dyno session with it soon too.
You do not have the required permissions to view the files attached to this post.

User avatar
drholl
MegaSquirt Newbie
Posts: 17
Joined: Wed Jul 02, 2008 8:49 pm
Location: California, USA

Re: Holden HQ one tonne ute

Postby drholl » Tue Jul 29, 2008 8:04 pm

I'm looking to do the exact same thing to my 1960 Chevy with a 327 cubic inch V8. The Ute looks like it will be a winner!!
:yeah!:
Holl

MS-II, V 3, 2.886, LC-1. 1971 Chevrolet Monte Carlo 350, 270 HP. 1959 German Corvette, bought in Berlin. With a 160 "KPH" speedo. KPH??? - What were they thinking? 160 KPH is only 100 MPH. We can peg that in third gear!!! 1959 Cadillac, 502, huge Chrome Bumpers and really BIG FINS!!!

long283
MegaSquirt Newbie
Posts: 13
Joined: Fri Jun 02, 2006 6:01 pm
Location: Sydney, Australia

Re: Holden HQ one tonne ute

Postby long283 » Tue Aug 05, 2008 6:06 pm

Ok, I've been playing with the tune for a little while and have managed to get pretty good performance out of the engine as well as reducing the tip-in.

I have found the 85lb/hr injectors too big (I knew this would be the case but couldn't find any 45lb/hr injectors here in OZ) so I have disconnected the secondaries and two of the injectors while I try to improve the starting and idle.

The biggest problem I have had so far is an intermittent fault causing the engine to cut-out. This usually happens at traffic lights just before they turn green or half-way through a round about :oops: This is very frustrating for drivers behind me & me while I'm trying to tune. From the data-logs & watching my laptop it appears as though it is losing the RPM signal for a short period of time. :RTFM: I am going to try changing the Hall input circuit to the MSnS E mod or the VR circuit to try and fix this.

I didn't have any trouble before when I was running ignition only but hope this will fix the problem.

long283
MegaSquirt Newbie
Posts: 13
Joined: Fri Jun 02, 2006 6:01 pm
Location: Sydney, Australia

Re: Holden HQ one tonne ute

Postby long283 » Tue Sep 23, 2008 2:04 am

After changing the Hall input circuit to the MSnS E mod the tach signal was a lot more stable. The car would still stall occasionally for no reason. I think the problem was being caused by the low-impedance injectors and PWM. The 85lb/hr Holley injectors weren't very good at atomising the fuel either.

I purchased a second hand Weind Team-G manifold and modified it for injectors and made custom fuel rails. I was still able to use the Holley throttle body after removing the injectors, fuel press. regulator and blanking off the holes.
I used 8 high impedance injectors from an LS1 and a fuel-pressure regulator from a Holden VS Commodore. The regulator fits in the end of the fuel rail with an adapter made from brass. Three inches of carb spacer were used so the kickdown lever would clear the left fuel rail.

After the change the car started first go and with a bit of tuning is idling a lot smoother.

This is the manifold, injectors, fuel rails and regulator.
Image

The finished conversion.
Image

Overall I'm very happy with it now. Just needs the final tuning and maybe a dyno session.

Bonnet clearance has been reduced with the spacers and will need a hole cut in it to fit an air-cleaner. Hopefully covered by a reversed cowl scoop.
Image

long283
MegaSquirt Newbie
Posts: 13
Joined: Fri Jun 02, 2006 6:01 pm
Location: Sydney, Australia

Re: Holden HQ one tonne ute

Postby long283 » Tue May 26, 2009 8:00 pm

Here's a picture of the ute with the A9X bonnet scoop (similar to Camaro/Chevelle induction hood) that covers the hole in the bonnet for the air cleaner.
Image

Since doing the dyno tune and data logging during a couple of long drives I think the mapping is quite good now. I changed the throttle linkage to get a better leverage angle and have the mechanical secondaries coming in after 1/3 throttle to reduce the tip-in.

I also picked up a brand new slightly marked 100amp alternator at a swap meat for AUD$40.00, which I am going to fit as soon as I change the pulley.

So far I am quite pleased with the whole package. The only thing letting it down is the engine build, the engine keeps fouling plugs with oil. This could be the piston to bore clearance, guides/seals or the sump (cheap made in china crap :x with no windage tray) & rocker covers letting too much oil get pulled through the PCV system. I am setting the goal to get the body & paint cleaned up first before I build another engine (no I didn't build the 350 that's in there at the moment). If I do build another engine I may change to a crank angle sensor and DFI to handle higher revs and make better use of the manifold/EFI. The wishlist is AFR heads, roller cam, quality sump, stronger conrods, balancing, higher-stall torque converter & tuned length headers reving to around 6500rpm. Can't decide on if I should build a 350 or 383.
You do not have the required permissions to view the files attached to this post.

long283
MegaSquirt Newbie
Posts: 13
Joined: Fri Jun 02, 2006 6:01 pm
Location: Sydney, Australia

Re: Holden HQ one tonne ute

Postby long283 » Thu Jul 14, 2011 3:05 pm

Latest Update.

ECU: MS2 v3.0
Firmware: MS2-Extra Realease 2.1.0q
Mods: Transistor buffered tach. input circuit (custom design).
Modified daughter board for sequential-code - Not yet in use.
4-ch Fuel & 4-ch Ign board installed - Not yet in use.

Engine: Small block Chev, 4-bolt mains.
Crank: 3.75" stroke.
Heads: AFR
Intake: Weiand Team-G, modified for injection.
Fuel rails: Custom.
Throttlebody: Holley Pro-jection, TBI & fuel press. reg. removed.
Injectors: LS1.
Regulator: VS Commodore.
Cam: XFI-roller.
Exhaust: 4-2-1 headers, 2.5" dual, balance pipe, 2 x straight through glass-pack mufflers, 2 x resonators.

The new engine is a lot better. It may require bigger injectors as the duty cylces appear to be maxing out at ~5000rpm. The fuel pressure needs to be higher too as the LS1 injectors are rated at 3.5Bar (50.76psi) and the VS commodore regulator is set at 3.0Bar (43.5psi).

When I pulled down the last motor everything looked good except the heads, all the valve guides had at least 0.015" clearance!!! :evil: Not happy. Very glad I built the current engine myself and was able to check all the tolerances myself.

The attached photo shows what is being planned as the next mod. Will also modify the wiring harness for the semi-sequential injection and coil-packs.
You do not have the required permissions to view the files attached to this post.

long283
MegaSquirt Newbie
Posts: 13
Joined: Fri Jun 02, 2006 6:01 pm
Location: Sydney, Australia

Re: Holden HQ one tonne ute

Postby long283 » Wed Feb 27, 2013 1:29 am

Ute was driven ~4500km across the country. Relatively trouble free, except had a blocked fuel filter at Hay, believed to be caused by a batch of fuel containing ethanol cleaning out the tank and all the crud ending up in the fuel filters. Also found the main earth lead a bit loose at one point.

Attached should be the final .msq file that was loaded in before the drive. Can't check it whilst the car is on the opposite side of the country.

MS2_Extra Rel 2.1.0q
Using TunerStudio v1.004
You do not have the required permissions to view the files attached to this post.


Return to “General Motors”

Who is online

Users browsing this forum: No registered users and 1 guest