Colin Doyle, 1985 Merkur XR4Ti 16v - MSnS-E on PCB V2.2

Ford, Lincoln, Mercury, Merkur, etc.
Post Reply
Colin Doyle
MegaSquirt Newbie
Posts: 4
Joined: Sun Jul 24, 2005 7:15 pm
Location: Saint Cloud, MN
Contact:

Colin Doyle, 1985 Merkur XR4Ti 16v - MSnS-E on PCB V2.2

Post by Colin Doyle » Tue Jun 20, 2006 9:44 pm

Name: Colin Doyle
Vehicle: 1985 Merkur XR4Ti

Engine: I have modified a 16-valve head from a Volvo B234 to fit the Ford 2.3L block. The Holset turbo (from a Cummins Dodge) is supported by a home-made log manifold. On the intake side, air exiting the Isuzu NPR intercooler enters a 65mm throttle body from a Ford 4.6L, which is fitted to a modified intake manifold from a Ford Sierra Cosworth 4x4. The intake manifold, in turn, has had a Volvo flange welded to it. Some careful porting with a die-grinder allows the Cosworth runners to line up with the Volvo ports. The bottom end of the engine is currently bone-stock, with 160k miles on it, and the head has not yet been ported.

The Goods: V2.2 PCB, MSnS-E
Injection: Port-injected, stock 35 lb/hr Ford browntop injectors (for now... just to get it running)
Ignition: Ford EDIS-4

Description: I believe this is the third running 16V head swap on a Ford 2.3, and the first to be Megasquirted (the other two are running on SDSefi.) I'd like to thank Phil Marshall, all the helpful people around the Megasquirt community, the fine folks over at turboford.org, and all my Merkur buddies for the inspiration and motivation to keep going on this project.

Website: http://homepage.mac.com/limefrog/
Video: http://video.google.com/videoplay?docid ... 5017801870

Thanks,
Colin
Colin Doyle
Image
1985 Merkur XR4Ti
V3.0/MSnS-E/EDIS

Colin Doyle
MegaSquirt Newbie
Posts: 4
Joined: Sun Jul 24, 2005 7:15 pm
Location: Saint Cloud, MN
Contact:

Post by Colin Doyle » Mon Jun 26, 2006 5:52 am

I'm having some trouble with my EDIS install... seems it won't advance timing from 10 BTDC. More information here.

Thanks,
Colin
Colin Doyle
Image
1985 Merkur XR4Ti
V3.0/MSnS-E/EDIS

Colin Doyle
MegaSquirt Newbie
Posts: 4
Joined: Sun Jul 24, 2005 7:15 pm
Location: Saint Cloud, MN
Contact:

Post by Colin Doyle » Sat Apr 07, 2007 2:35 pm

I ended up not being able to get my V2.2 setup to advance timing - I tried everything and it was still locked in dead-solid at 10BTDC... so I built a V3.0 board, performed the EDIS mods, and it fired right up and advanced timing. :?

NickK (member here) has revived my V2.2 board and is now using it in his '95 Ranger 2.3T.

Colin
Colin Doyle
Image
1985 Merkur XR4Ti
V3.0/MSnS-E/EDIS

Post Reply