390 1964 Ford Galaxie 500

Ford, Lincoln, Mercury, Merkur, etc.
jet471
MegaSquirt Newbie
Posts: 7
Joined: Thu Jan 27, 2011 10:02 am
Location: Jackson, MS

Re: 390 1964 Ford Galaxie 500

Post by jet471 » Sun Apr 03, 2011 8:01 pm

Thanks for responding 64Ford, I can't wait to test it out.

Verified this weekend that the computer is working on the vehicle, and picked up most parts at the pull a part.

677litre
MegaSquirt Newbie
Posts: 1
Joined: Tue Apr 19, 2011 8:53 am

Re: 390 1964 Ford Galaxie 500

Post by 677litre » Tue Sep 13, 2011 10:35 am

Hi 64Ford, and others running MS on an FE. So I'm looking for any advice and recent base maps someones willing to share for this setup. Some tweaked spark and ignition maps would be cool to help start me out.

I'm in the process of if installing a M3+M3X V3.57 onto my 428FE. It will be MPFI and speed density since I'm going to use dual quad TBs. I have a complete EDIS setup I might install but for now I'm considering using one of the FAST dual sync dizzys but probably run batch fire to begin with instead of sequential fire until things are running smoothly. Any suggestions on other good working cam sensor options? I have an old dura spark dizzy that I could modify with only one tooth but the headaches of setting up the phasing is what leaning me towards the FAST dizzy. Anyone running dual O2 sensors and if so any issues?

Anyway, just kind of introducing myself and looking for advice on setup and tuning and FE. This will be going into my 67 Galaxie. Cheers. :)

64 Ford
MegaSquirt Newbie
Posts: 32
Joined: Tue Feb 05, 2008 5:27 pm
Location: Cocoa Beach FL

Re: 390 1964 Ford Galaxie 500

Post by 64 Ford » Mon Sep 19, 2011 5:45 am

67 7 Litre,
A dual TB 428 sounds like fun! If you look at the previous posts I put a couple of my .msq files out there so that should be a start. As for the EDIS, I just made my own crank trigger using 3.0 V6 Ford parts. But I've been also thinking if I sep up to MS 3 modify a distributor w/Duraspark guts; morph one to use a Ford style cam shaft position sensor, or use the mechanical fuel pump boss to mount a sensor to capture the signal from the camshaft sprocket. I like modifying/tinkering off the shelf OEM stuff kinda goes along with the whole DIY theme of the Megasquirt. I do have dual O2 sensors-a WB on one bank and narrow band on the other. The WB signal goes to the MS & AF gauge. I've wired a toggle switch to the narrow band & AF gauge to help validate between the two. I believe there is a section in the MS manual or forum on how to wire it up for dual O2's. I do run a MAF sensor; in my instance it helped immensely with idle an low rpm smoothness. My next mod is to install COP once I finish fabricating the brackets & valve covers.
64 Ford

64 Ford
MegaSquirt Newbie
Posts: 32
Joined: Tue Feb 05, 2008 5:27 pm
Location: Cocoa Beach FL

Re: 390 1964 Ford Galaxie 500

Post by 64 Ford » Sun Jan 22, 2012 8:43 am

:cry:
I hate to say it but mother nature has won the battle to eat my car. I haven't really played with the MS in about a year to focus on the body. Started to work on the roof and found a 3 ft section by the drip rail rusted away. I think the paint was the only thing holding it together. So I'll try and find something to transpant the 390 into or have to part it out. :(
64 Ford

Renegdz
MegaSquirt Newbie
Posts: 2
Joined: Wed Sep 05, 2012 10:32 pm

Re: 390 1964 Ford Galaxie 500

Post by Renegdz » Wed Sep 05, 2012 10:49 pm

Hi 64Ford!!, another 390 (FE) nut here, I planned on injecting mine with all ford hard and software but seeing your build has me very very interested, I hope you managed atleast a transplant, any updates getting ready to "Cobble" mine soon.

64 Ford
MegaSquirt Newbie
Posts: 32
Joined: Tue Feb 05, 2008 5:27 pm
Location: Cocoa Beach FL

Re: 390 1964 Ford Galaxie 500

Post by 64 Ford » Sun Nov 04, 2012 12:31 pm

Thanks for the kind words. I haven't been able to find a suitable car to transplant; salt/ocean eats cars here in FL. I'll probably swap the motor back to a carb in a few weeks, sell it, and save the megasquirt for another car. :cry:
64 Ford

64 Ford
MegaSquirt Newbie
Posts: 32
Joined: Tue Feb 05, 2008 5:27 pm
Location: Cocoa Beach FL

Re: 390 1964 Ford Galaxie 500

Post by 64 Ford » Mon Dec 31, 2012 6:20 pm

Wish all a Happy New year! http://www.youtube.com/watch?v=9SYxg8Urzm8 is the you tube link of last run before I pull the Megasquirt off the car. You can see how the salt has eaten the car away...:( :(
64 Ford

64 Ford
MegaSquirt Newbie
Posts: 32
Joined: Tue Feb 05, 2008 5:27 pm
Location: Cocoa Beach FL

Re: 390 1964 Ford Galaxie 500

Post by 64 Ford » Thu Mar 14, 2013 4:58 pm

Discovered after I pulled the intake need to change injector angle. They need to "lean" in so they squirt more at the valve instead of the port floor. Will add a pic in a few days.
64 Ford

64 Ford
MegaSquirt Newbie
Posts: 32
Joined: Tue Feb 05, 2008 5:27 pm
Location: Cocoa Beach FL

Re: 390 1964 Ford Galaxie 500

Post by 64 Ford » Sun Mar 31, 2013 2:25 pm

Here are the pictures of the ports. As you can see the fuel was hitting the port floor instead of the valve. But hey I don't feel bad since I fabbed it all up using my Harbor Freight 39.95 drill press and parts from U-pull its/Pick n pulls from across the country. I'm in the process of getting rid of my Galaxie due to rust and separating from the USAF this summer so until I find another job it will be on hold. Hopefully I can find aanother FE powered project and press on with the Megasquirt. I will still answer an questions of what I did for this install.
You do not have the required permissions to view the files attached to this post.
64 Ford

64 Ford
MegaSquirt Newbie
Posts: 32
Joined: Tue Feb 05, 2008 5:27 pm
Location: Cocoa Beach FL

Re: 390 1964 Ford Galaxie 500

Post by 64 Ford » Tue Aug 27, 2013 6:29 am

Sad day sold the car :( . I may sell the intake & parts in the near future if I can't find another FE powered car/truck to put it on.
64 Ford

Post Reply