Blown 4.6 1996 Cougar with a 4r70w

Ford, Lincoln, Mercury, Merkur, etc.
Post Reply
2ton
MegaSquirt Newbie
Posts: 1
Joined: Fri Apr 23, 2010 6:10 am

Blown 4.6 1996 Cougar with a 4r70w

Post by 2ton » Fri Apr 23, 2010 6:38 am

I've had this thing running for a season and a half now, and it's primary duity is street racing. I originally planned to flash the factory computer due to having an electronically controlled transmission with way more stall than the car really needs :P Unfortunately, the tuners in my area suck, and the only "Reputable" mail-order tuner providing for my platform decided to be a complete flake. Where I come from, we don't let people stand in our way. I ordered an LC-1, MS2 3.57, cut up an old wiring harness, and had the car driving in a weekend.

The car has a forged PI 4.6 motor by Renegade Racing, a Vortec V1 S-trim supercharger with a 3.1" pulley (13 psi), 42lb injectors, Headers, exhaust, built 4r70w transmission with a 4000 stall locking torque converter, 4.10 gears, springs, shocks, and much more. I'm still unsure what it will do at the track with a clean run. The few passes I was able to get towards teh end of the season were terrible. On one run, I spun off the line, let off until I hooked, Gassed it again, spun more, watched the trailblazer SS I was racing take about two cars on me, FINALLY hook, blow past him, start to ping, let off at the 1/8th, and end up doing a 13.7 at 87mph and beating the trailblazer. I KNOW there is more in the car, but fueling became a problem when the air temps dropped. We'll see what this season brings.

The tranmission control was the biggest challenge with this car... I had previously had a tune written for this setup, and it was soo horribly done that it would foul the plugs before I got to the top of the driveway... This all while having tremendous amounts of vacuum leaks.... It was pathetic, and the "Tuner" provided no support even after 6 weeks trying to contact him. With MS running the motor as a piggyback, leaving the MAF and other sensors in place, the transmission did OKAY but it would slip at higher RPMs... I remedied this a ilttle bit by suplimenting the MAF input to the ECU with TPS voltage to simulate a lot more airflow than I was really seeing. This, once again, ALMOST worked... There were driveability issues, and it still did not command high enough pressure to hold gears. Something was going to have to give...

I ended up going with a Baummannator TCS (I have no freaking idea how to spell that, so sue me if it's wrong)... There are a LOT of mixed reviews about the TCS... I really haven't seen any FIRST HAND experiences with it that were negative aside from the flaws I point out myself... But I didn't know about those at the time... The install was easy. It took two drunken evenings while the girlfriend at the time was out of town to install. Electronically, the installation was easy. The tuning was a bit complicated because of my rear-gear change... After I finally figgured out what values to use to get my speed reading accurate in the TCS software I was able to finally get a tune made and adjust my shiftpoints... It took a while...

While I was out one night, before the big mustang+camaro meet/racing night, I was out crusing around trying to get my shiftpoints dialed in... I see this black 03 cobra clone comming up on me, and as he gets next to it, I lay on it. My car downshifts, then makes TERRIBLE noises at the poor mustang... I had mis-calibrated my shiftpoint and saw rev limiter in first, very violently, and was shooting flames out of the exhaust... I did not know until the car show that said mustang ran mid 9s.... how embarrasing.

I'm going to re-do the TCS tune, since it has it's defects. Load is TPS based, and should (and will) be MAP based.... The torque converter controlability sucks horrendously. There are three variables for the entire algorythm... Minimum gear, minimum MPH, and maximum TPS... LAME. I'm going to have to live with it for now unfortunately. Additionally, there is a problem with transmission pressure control. Transmission pressure is a factor of load only. Well, I can be at 6000rpms at low load, or I can be at 1000rpms at low load. Both situations require a vastly different amount of allowed fluid flow since the pump is beign driven at different speeds. I'm not sure how to remedy this either, but my transmission is still holding strong... Just be warned.

Oh, and I ended up getting rid of MAF related crap, and adding a lot of check valves.. You'd be suprised where boost ends up.

Over all, I love my Megasquirt, and do not at all regret my decisions. I'm also running MS2 on a Mitsubishi, but likely will pull that unit for a MS3 setup with coil on plugs, and put the MS2 computer on a Cammed LS1 Miata with Nitrous I'm peicing togeather.

Post Reply