95 Ford Escort - MS2 v3.0

Ford, Lincoln, Mercury, Merkur, etc.
Post Reply
95SuperScort

95 Ford Escort - MS2 v3.0

Post by 95SuperScort » Wed Aug 25, 2010 4:19 pm

Hmmmmm, where do I start... Hi my name is Zack and I have a 95 Ford Escort. Engine Mods include 3.8L throttle body from an explorer, OBX Headers, Port and Polished Intake manifold, Cold air intake with a relatively small cone filter, and a few sensor removals including DPFE, EGR, carbon canister and everything with it, stock o2 replaced with Innovate LC-1. I bought the MS2 in February and put it together by May. I had no maps so I used everything from a miata of the same year (hoping it was close) and set everything up on TunerStudio. Plugged in the MS and on the first try she ran, idled pretty decent but definitely not tuned. At this time I did not have the wideband in because I was switching between the stock ECU and MS2. Finally got the balls to switch over completely and started tuning. First day I switch over to start tuning my 2 year old radiator sprung a bad leak and needed to be replaced. I bought a new one and started tuning. I set up what I thought was a decent AFR target map and used auotune to get me there. The car was running great for about 2 days and noticing the coolant temperature rising I knew something wasnt right. Parked the car at a friends house and went to leave 2 hours later, tons of white smoke poured out from the exhaust, of course smelling like coolant. After about a minute or two of revving the smoke went away and I drove home. Same thing the next day except this time the motor wouldnt turn over. At that point I knew something was seriously wrong, and while driving home I saw the temp go from 180 to 220 in between stop lights. Not good! Thinking head gasket I pulled the head off and checked the gasket, it was fine! so I took the head to my machine shop, cracked! Long story short I got a new head online with only the valves (springs, seats, retainers) in it and swapped over my cam, lifters, rockers and clips. I also found out that my lifters were bad too so I had to get them new also. I figured since Im Megasquirting I could remove all of those unnecessary sensors and the ugly EGR valve. I bought headers, re polished the intake mani, cleaned a bunch of stuff up and I just got her up and running within the last week. As of now I have an OK tune that I can daily drive on but I can tell its slower than with the stock ECU. It obviously needs to be tuned and I was hoping to get good power and good highway mileage. If anyone needs help getting their escort running or wiring diagrams, PM me. Thanks for reading and any info would be appreciated. And if you think I forgot something dont hesitate to ask :yeah!:

turboman
MegaSquirt Newbie
Posts: 1
Joined: Tue Oct 28, 2014 5:20 pm

Re: 95 Ford Escort - MS2 v3.0

Post by turboman » Tue Oct 28, 2014 5:23 pm

I was just wondering if you still visit this site I have a escort as well just looking for some MS info.

Post Reply