my mk2 20vt

Post Reply
carlg
MegaSquirt Newbie
Posts: 1
Joined: Wed Dec 17, 2014 10:00 am

my mk2 20vt

Post by carlg » Wed Dec 17, 2014 10:07 am

Hi here is my mk2 20vt golf running on ms2 extra.

Below is a thread i started on our closed VWDRC Forum covering my first year, sorry if it rumbles on a bit lol......


Well now that my racing is finished for the year I suppose its time for me to start a build thread for my car, this season has been really fun and I plan to race next year too.

I started building the car two years ago mainly because I fancied building a fast car and the old commuter car was sat in a corner of a barn and i had tried to sell it but failed....

Image

I then built the first incarnation using an AGU engine from a A3 1.8t I bought as a runner.

the first spec of the car was

Bone stock AGU
stock k03 turbo
020 td mk3 box
new stock 8v clutch - more on this in a minute
all running on megasquirt ms2 extra
using the stock 8v mounts (note don’t do this)
intercooler that i picked up new for £10 from an autojumble (bmw one)
Qpeng 2.5 inch downpipe into a reducer into the stock exhaust
everything else was stock....

I then went to big bang 2013 and did 27 runs and netted a best of 14.7 which i was quite impressed with, on road tyres - only removed passenger seat and rear seat and anything that wasn’t needed....

I then drove home fine then on my way to maplins to pick up a couple of switches etc the golf spun 5th gear so the box was changed to the old 8v box (not a good choice for this conversion btw)

The next event I went to was Apex festival after putting some track tyres on (federal 595 RSR) my ronal turbos (they are silly heavy though :( )

Image

note the black wanger in the background!!

I was having fun however the engine mounts had the cam wheel too close to the master cylinder and round left hand bends when driving enthusiastically it would hit and make a really horrid noise, I found that I could make it not hit by wheel spinning round the corner.

I did about 40 minutes of track time but had to retire due to a slipping clutch, I only just managed to drive it home (needed help and got pushed up the hill from the paddock :? ) once I took the clutch out i was greeted with this

Image

I then decided to upgrade to a 02a box with a g60 style flywheel (vr6 clutch) this normally requires a conversion to a hydraulic clutch however certain seats used a cable mech for the clutch, I found a seat toledo TDI (mk1) for sale for scrap money so i picked that up took the gearbox flywheel clutch cable and gear linkage. i also took the front cross member (mk3 style mount)

Whist i had all of this out i also changed the subframe for a mk3 cabrio that my dad was scrapping also fitted the front brakes (256mm) and tried to fit the widetrack mk3 setup however the cabrio was a auto and I didn't have the longer mk3 manual driveshaft’s to I fitted new mk2 wishbones (the extra width is in these) I also used the mk3 power steering rack which now needed the mk2 arms fitted (width again) I used all the Toledo engine mounts

Once the car was back together I realised that I had no compression on no 4 looking at the logs I had over revved the engine to about 8k so rather than messing about I wanted more power so I found an early s3 engine (apy) without the ecu so next up was a new downpipe this time from trackslag for the K04 engine still with the reducer and the 8v exhaust, a few tweeks to the map (mostly for the bigger injectors) and she ran on the maiden test drive I found that my fuel pump was not good enough (stock digifant) and I burnt a valve changed the valve and on the first run up it dropped the new valve (apparently they can do this if fitted incorrectly :( ) this killed the S3 enigne ...

****ed off I bought another AGU engine for a couple of hundred, fitted all of the s3 parts and got her running again on a mk2 16v fuel pump

BUG JAM 2013:

I took the golf and managed a few low 14's then got a 13.5 also got this awesome pic
Image

I was also talked into racing next year, but I was struggling to decide if to run in sportsman or pro ....

over the winter I fitted a full 2.5 inch trackslag exhaust and Rob Judge fitted my cage after I stripped the interior out, he did an awesome job with a very quick turnaround (dropped the car off and picked it up a week later) it’s also been tagged down to 10 (the tech guy said a 8.5 will be no
problem :) ) I also picked up a wizards of nos nitrous kit off an old drag car, also bought a set of 22-8-15 inch slicks used. oh and a big ish holset turbo

Image

my dad then painted it (twice) - Thanks dad

Image

over winter I found an issue that occurred twice if I didn't limit the boost down low on a hill the stock rods would end up like this:

Image

Image

I bought a set of IE Rods off the shelf and fitted them to the first engine that I bent rods in it ran fine however it smoked badly, as I had honed the bores and fitted new rings I thought I had made a mistake, so I bought a cheap (£200 delivered) set of eBay rods which arrived next day fitted them to the other engine I bent rods in and still had the same issue, turns out that the turbo was dying, sent off for a rebuild whist the K04 was off I decided to take this pic showing the new turbo next to the K04

Image

then came Big Bang 2014....

had a rubbish time it ran ok until about mid track then would misfire badly my pb over the weekend was a 13.4 tried the gas anyway and blew my intercooler apart :(

I skipped the Easter event and ordered a new intercooler (eBay special £70) and spent the weekend trouble shooting, midday Sat I found the issue i had changed the feed line to the ECU and it was dropping voltage when load was applied reverted back to the old feed, and like magic the issue was gone....

Spring Speed

first run out netted a 12.7 without gas turned the boost down a bit (was at max boost) and still ran a 12.8 I decided to run a 50 shot dialled in 12.4 ran 12.37 with a 1.78 60ft Very happy carl :)

Apex

Went and played at apex on the Sunday had a good time car was driving well I saw off a couple of track prepped 944's and held my own with a lotus :)


Summer Nats

had a good time, tried a 100 shot of gas and managed a 12.5 @ 114mph

Bug Jam

had an awesome time, after the second run my car felt very strange on investigation the diff was locked solid, as the box wasn't leaking I decided to run as it was did a couple more runs and managed a new pb of 12.2 @115 but broke the box on the return road (how lucky) as I was coasting down the bit that had lodged in the diff came out and smashed through the diff housing :(

a quick call to my dad had him coming up early doors Sunday to bring the gearbox that I had been building up (with LSD)

box was almost out by the time my dad arrived with the box and the trailer

Image

after a hard mornings work we had the box back in but the front was still off the car, we were called 5 minutes later they asked if i was going to run... I asked how long do i have? about 2 minutes was the lady’s reply about 4 minutes later i was staging next to Dave with most of the front on the car.... I need to say thanks to everyone that helped me with this and also to Dave for waiting till the last pair for me..

great weekend ended up getting through 2 rounds

after bug jam I had the wishbones off again to change the subframe bushes as I thought they were getting tired and upgraded them to R32 ones also took the opportunity to stich weld the wishbone halves together.

on to Open sports nationals

I had a very bad start to this event about 8 miles from Shakey on the Friday the golf dropped an exhaust valve on number 4, RAC recovered me home and I got home about 3 in the morning, spent the next day (my birthday btw) fitting the spare engine (from when the turbo got rebuilt) when I took the exhaust manifold off i was able to see the valve head, It had not gone through the turbo..... Happy days :)

Image

I managed to get it in an running and drove upto shakey for about 8pm and had a massive welcome from everyone in the pits (Thanks guys and girls)

next day I ran another PB a massive drop to 11.62 @ 119 mph

On my way home from Shakey one of my output flanges on the box popped out, so I swapped in a spare that I had borrowed 5th from (TDI box) and ran that

VW Action

this was a testing day for me the golf ran fine (although my bottle heater broke so nos pressure was all over the shop) managed a few 12's also lent the golf to my little sisters Boyfriend as he was a massive help at bugjam fitting the box, first time on the strip 12.5 I think he might have the bug.....

National finals

I decided to end the season on a high and try a 150 shot of gas, although the engine was fine (new mph PB 121) it just span on the start line sad times so dropped back to 100 shot.

GTI Festival

I really enjoyed this event, managed a new PB of 11.57 @ 117.9 and won my class (F)

Image

Japanese Show Finale

Because i didn't want my first year drag racing to end I decided to enter the final round of the FWD series, armed with a new bottle heater, I tried my luck racing in this heads up class, Knowing that I am at least a second off the pace of the slower racers it was a good chance to see how I could do, I only managed an 11.8 as I was struggling to launch it, still the car drove there and drove home although I think a cv joint is going.

so that was my year I hope I didn't bore you too much and I hope your year was as fun as mine.... see you next year

Post Reply