1975 BMW 2002 - Forced Induction

synackack
MegaSquirt Newbie
Posts: 7
Joined: Wed Jun 14, 2006 3:42 pm

1975 BMW 2002 - Forced Induction

Postby synackack » Mon Jan 29, 2007 1:30 pm

Name: Tom

Vehicle: 1975 BMW 2002

Engine: BMW M10 (1.8L), originally converted to analog EFI.
** This engine now has BMW, GM, and Ford products
** Rajay 300e turbo charger from old BMW turbo conversion kit

Injection: 42lb/hr Merkur / port injection.


This has been a slightly daunting work in progress. What started out as a MSII conversion has turned into a nearly complete rebuild.

Some tear down pictures - or what I like to call: "Before"
http://www.dataspew.com/gallery/main.ph ... d65b3ace4b

Current WIP pictures
http://www.dataspew.com/gallery/main.ph ... temId=1867

The engine is finally back in / car is almost complete re-wired. I'll take more pictures and notes.

synackack
MegaSquirt Newbie
Posts: 7
Joined: Wed Jun 14, 2006 3:42 pm

It runs!!

Postby synackack » Mon Mar 05, 2007 5:05 am

With the exception of my brand new $100 fuel filter leaking, everything is working perfectly!

It runs! It turned over and fired the first time!

Idle air control is my hand on the throttle body right now, but it runs great! I let it warm up to 140' and watched the idle enrichment drop down.

Pretty damned amazing to see such an amalgamation of different automotive parts work together.

I'll have the charge-air plumbing done this week, and some of the wiring cleaned up. As soon as that's done, I'll post more pictures.

Go Megasquirt!

synackack
MegaSquirt Newbie
Posts: 7
Joined: Wed Jun 14, 2006 3:42 pm

Postby synackack » Wed Mar 07, 2007 8:47 pm

Engine back in, car is still very much a work in progress. But it runs!!

http://www.dataspew.com/gallery/main.ph ... alNumber=2

Neon coil pack, Ford plug wires, Cessna turbo, BMW engine.

http://www.dataspew.com/gallery/main.ph ... temId=8530

synackack
MegaSquirt Newbie
Posts: 7
Joined: Wed Jun 14, 2006 3:42 pm

First 40 mile run, need wider tires.

Postby synackack » Sat Apr 14, 2007 3:08 pm

It has been raining all day, but I drove it to a friend's shop to weld up some real exhaust.

Under boost, the car breaks the tires loose in all 5 gears.....!

JustinL
MegaSquirt Newbie
Posts: 2
Joined: Tue Nov 22, 2005 6:03 pm
Location: Edmonton

Postby JustinL » Tue Jun 12, 2007 2:27 pm

Hey I was wondering how your project was going. Looks awesome! Were all the parts I sent you satisfactory? Did you manage to get the water injection working?

Good job, and I'd like to hear more driving impressions!

Justin
88 944 Turbo S- MS-II code 2.6

synackack
MegaSquirt Newbie
Posts: 7
Joined: Wed Jun 14, 2006 3:42 pm

Postby synackack » Mon Jul 09, 2007 6:25 pm

Updated pictures. A few to-do items, but it's running well.

http://www.dataspew.com/gallery/main.ph ... mId=195776

synackack
MegaSquirt Newbie
Posts: 7
Joined: Wed Jun 14, 2006 3:42 pm

Postby synackack » Mon Jul 09, 2007 6:27 pm

JustinL wrote:Hey I was wondering how your project was going. Looks awesome! Were all the parts I sent you satisfactory? Did you manage to get the water injection working?

Good job, and I'd like to hear more driving impressions!

Justin


Hey Justin!

Yeah, everything's worked out. The turbo failed! :) I found a place that sells parts and opted to rebuild it. I thought about going with a new T3/T4, but after seeing the Rajay F flow specs, and how everything fits I really wanted to keep that turbo in.

Boost doesn't build until about 4100RPM, but when it does - HOLY "crap".

synackack
MegaSquirt Newbie
Posts: 7
Joined: Wed Jun 14, 2006 3:42 pm

Update: I made a new exhaust system for T04E turbo.

Postby synackack » Sun Sep 16, 2007 6:43 pm

The Rajay was just too big of a PITA.

http://www.dataspew.com/gallery/main.ph ... mId=544890


Return to “BMW”

Who is online

Users browsing this forum: No registered users and 2 guests