240Z Turbo swap (MSII, EDIS)

Nissan, Infiniti, Datsun
Post Reply
TexasZX
MegaSquirt Newbie
Posts: 9
Joined: Mon Apr 13, 2009 10:47 am

240Z Turbo swap (MSII, EDIS)

Post by TexasZX » Mon Apr 13, 2009 11:58 am

Background:
I own a 240Z and one day a friend basically gave me a very used 1983 L28ET engine core. Everyone said that the turbo swap was easy (that it was just a drop in replacement) and use Megasquirt (since it's easy to configure) and use EDIS (since it's easy to control and reliable). It seemed like a no-brainer to go the "easy" route and just drop in a better engine and wire up better electronics. How hard could it be? :lol:

Notes
You have to control BOTH fuel and spark on the turbo engine with an ECU. If you keep the Nissan turbo dizzy just be aware that the turbo dizzy has no internal spark advance/retard mechanisms in it at all. All the 82-83 turbo dizzy has inside is an Hall optical crank angle sensor and a rotor. If you decide to scrap the dizzy for EDIS, then EDIS also sends out a Hall(square wave) signal from the EDIS module to MegaSquirt. Even though EDIS uses a VR sensor, the EDIS module itself converts that into a "hall type" signal (PIP) on Pin EDIS #1 to send out to Megasquirt's Pin 24. Set up MS for a Hall input, not VR.

Megaquirt Parts:
DIYAutoTune MS II V3.57
DIYAutoTune 12' direct wiring harness
DIYAutoTune pre-built "Stim" card
DIYAutoTune GM water and air temp sensors

Engine Parts:
1983 280ZXT engine (F54 L28ET lower end rebuilt by me, with P90a hydraulic head rebuilt by a shop)
T3 Turbocharger (rebuilt by turbochargers.com)
1975 280Z early EFI intake manifold (very clean and simple, no EGR, no webbing)
Stock 265cc Nissan "turbo" injectors (rebuilt ones from "Mr. Injector" on eBay)
Nissan fuel pressure regulator (new, genuine Nissan)
Fuel Rail (made by me from aluminum extrusion, fittings, and pressure gauge from Jegs.com)
280Z injector resistor pack (so no need to control injector current with MegaSquirt modulation)
Ford EDIS-6 ignition and coil pack (so no need to control coil dwell, used from Camano Island, WA on eBay)
Nissan early 2 row harmonic balancer with "bolt on" 3rd pulley (required to adapt on a 36-1 wheel).
240sx TPS sensor (with mounting plate cut from old 280Z throttle switch, BECK/ARNLEY Part # 1580490)
Narrow band (heated) O2 sensor, Bosch 13030 (AutoZone)
Electric radiator fan (due to clearance problems with a 1983 clutched fan, Flex-a-lite low profile)
Silicon hose adapters and tubing (for cold air ducting down to turbo inlet from ExtremePSI.com)
4 Diodes to the 3 coil pack leads to drive Tach (3 1N4004DICD-ND and 1 1N4746ADICT-ND from Digi-Key)
160F thermostat (new, genuine Nissan)

Car Parts:
280Z tachometer
1975 280Z EFI gas tank (has internal baffling so no need for a surge tank)
Walbro GSL392 High Pressure Electric Fuel Pump (DIYautotune.com)
New larger fuel line and new fuel return line
New exhaust system to mate with new downpipe and then replaced all the way back (Meineke muffler shop)
New underhood fuse block for all new +12V lines driven by a 60 amp relay from "key on 12V"
5 speed ZX transmission swap(not technically required) and new 240mm "turbo/2+2" clutch disc(required)

Summary:
It starts and runs fine. I had to learn more about engine controls, custom fabrication, and tuning on this project than anyone can imagine. If I had to do it all over again on a 240Z, I'd just throw in a regular L28 with carbs and a stock ZX dizzy and just enjoy a reliable cheap power increase(and leave the entire rest of the car alone). There is a huge sense of accomplishment but it's impossible to justify the money and time spent. Best of luck for those that start such a turbo/EFI/Ignition conversion project on a 240Z.
Last edited by TexasZX on Tue Jun 02, 2009 7:20 am, edited 10 times in total.

TexasZX
MegaSquirt Newbie
Posts: 9
Joined: Mon Apr 13, 2009 10:47 am

EDIS Woes

Post by TexasZX » Wed Apr 15, 2009 11:03 am

First update after initial start and run proved successful:
I found out that the common saying I've heard posted everywhere that "EDIS module can operate the engine by itself in a limp-home mode" was a huge exaggeration about it's reliability. Fact is that there are 3 points of failure on the system. The used EDIS module itself died but fortunately it was during tuning in the garage. That was an easy one to isolate.

The next item that died was one of the coils in the used coil pack and I "limped home" on 4 cylinders (with fuel smells and a slight backfire) last night for about a mile. Thank goodness it was "coil A" because first thing I did was shoot the timing and failed to get any "flash" at all while the engine was idling roughly. I wired in a single old standard coil to bypass coil A and ran the single high tension wire to #1 and spark was fine then and it showed a normal timing. New coil pack is on the way and car is dead till then (again).

Edit: To test an EDIS before installing, you can "play" a music file to the module and watch the coil pack discharge:
http://www.heggs.co.uk/vrssim/wav/index.htm


Edit: The problematic used EDIS "system" of coil, module, VR and trigger wheel were bought from eBay from a guy located in Camano Island, WA. I just saw that he now is going by a different name on eBay. Id suggest anyone else use a reputable dealer that tests the unit like http://www.boostengineering.net/product_p/edis6kit.htm
Last edited by TexasZX on Mon May 11, 2009 5:55 am, edited 3 times in total.

TexasZX
MegaSquirt Newbie
Posts: 9
Joined: Mon Apr 13, 2009 10:47 am

OK, I Need a Wide Band O2

Post by TexasZX » Mon Apr 20, 2009 4:59 am

The "runs fine" was a bit premature. An overly lean mixture is being seen on the spark plugs(white electrode) and water temp is 20-30 degrees hotter than normal now that I took the car on the road a few times. The heated NB O2 was reading hard-over lean so I replaced it with an DIY Autotune LC1 WB02 (with blue digital gauge) just to "see" how wrong the mixture was. After the free air calibration and then swap into the place of the NB sensor, the WB02 is fluctuating wildly 17-21 AFR so either it's sucking in a LOT of air into the exhaust system (from a leak I can't hear?) OR there is a quirk in placing the sensor in the stock position so close to the turbo OR I was unlucky enough to buy 2 dead-on-arrival brand new O2 sensors (NB and then a WB)? No way that the ~20:1 is a real indication since the engine is more or less drivable and making decent power. In both cases I disabled the 02 on the MS to get the engine running from a best guess MAP/VE table.

I'm at a complete stop(again) until I can get a REAL wideband O2 reading before proceeding to address the actual (but modest) over-lean condition I'm seeing on the engine. Again I'm stuck diagnosing some peripheral issue instead of getting to the real business of diagnosing/tuning the engine just to make it roadworthy. Next step is testing the WB O2 on some other non-turbo engine just to confirm the "goodness" of the sensor and then if "good" to proceed to check on installation issues with the turbo manifold.
Last edited by TexasZX on Mon May 11, 2009 5:54 am, edited 1 time in total.

TexasZX
MegaSquirt Newbie
Posts: 9
Joined: Mon Apr 13, 2009 10:47 am

Bump up the Fuel, Plugs Look Right

Post by TexasZX » Wed Apr 22, 2009 4:49 am

Ok, the WB O2 was tested on the bench with an (unlit) propane torch aimed at it and it began to register in the 10-12 range. Re-installed the now known good WB (but now at 18" down pipe from the turbo ) and started working on the fuel control by reading the LC1 AFR gauge (now loosely mounted in the car) as the main guide and then tuning the VE tables and Req_Fuel in MS with MegaTune on a laptop to get reasonable AFR's. A check of the plug electrodes and they are now a light brown. This morning I gave it a 20 mile drive and the turbo engine is making good torque and is very drivable. Now on to the sizable job of tuning for both power and economy and longevity with this new arrangement of stuff now that it's stable.

Sorry to chronicle all this but everyone I know just said "go megaquirt" when I considered a turbo conversion for my 240Z. I picked out what should have been pretty standard stuff for the project (including pre-built MSII and STIM to avoid as many unknowns as possible) and got started with it. What no one ever mentioned was that you basically have to become your own engine engineering department, fabrication technician, and then service diagnostic center . It took so much LONGER than expected just to get everything assembled that it was a big disappointment when I realized after assembly that serious work lay ahead with tuning "or serious damage could result" (since every installation is unique). All I can say is to get as much REAL instrumentation on the car as possible (fuel pressure gauge, EGT, WB O2 with it's own gauge, timing light, boost gauge) so you KNOW what's REALLY happening in the engine and THEN make sure that the Megasquirt/Megatune is following along with that reality. I'm STILL not really done.

If you do everything correctly, the engine will eventually run as well as a typical production engine.
Do just one thing less and it won't.
Last edited by TexasZX on Mon May 11, 2009 5:56 am, edited 1 time in total.

TexasZX
MegaSquirt Newbie
Posts: 9
Joined: Mon Apr 13, 2009 10:47 am

Turbo = HEAT

Post by TexasZX » Fri May 01, 2009 5:59 am

More Conversion "gotchas" .
Every picture I remember seeing of turbo conversions must have been in the early stages of the build since none have any heat shields installed between the intake manifold and the exhaust manifold. I patterned mine after that "clean look" too but I noticed after a week of running that the fuel rail got too hot to touch! That can't be good. I still had the old metal shield in a parts bin so I shoved it in between the manifolds(well, you gotta remove the J-Pipe and move some wiring to get the thing in). While I was there, I also re-routed the injector wiring OVER the fuel rail and put on some round plastic wire coverings on the wires to better protect them.

NOW the fuel rail does not get hot at all. No wonder Nissan used a heat shield between the manifolds! :idea:

That makes me think that I'd better start shopping around for the 280ZX heat deflectors that protects the plastic brake master cylinder reservoirs and the brake lines too (since the hot side of the turbo and downpipe are even CLOSER to them in the smaller engine bay of the 240Z as compared to how things were arranged in a 280ZX). :!:
Last edited by TexasZX on Mon May 11, 2009 5:57 am, edited 1 time in total.

TexasZX
MegaSquirt Newbie
Posts: 9
Joined: Mon Apr 13, 2009 10:47 am

Even more "gotchas"

Post by TexasZX » Tue May 05, 2009 4:57 am

.
electrical load
The electrical load is a bit too much for the ancient 240Z alternator and old external voltage regulator. I'm getting swings in the voltage that are resetting the WB 02 sensor and (seemingly) causing irregular injector responses.
I've added the following fuse rated circuits to the car:
10 amp for electric fuel pump
20 amp for EDIS-6 ignition system
10 amp for electric cooling fan
Two 7.5 amp (one for each bank of 3 fuel injectors)
5 amp for the heated O2 sensor
2 amp for the ECU (Megasquirt)
Hopeful Solution: Tonight I'm adding a new and more modern higher amp rated alternator (with internal voltage regulation).



Cooling
The increase in cubic inches and adding a turbo are taxing the original old radiator. The 160F genuine Nissan thermostat is working, but coolant temps remain continuously around 190-195F. That temp is without turning on the A/C and air temps in the 70's.
Hopeful Solution: I have a 3 row aluminum radiator on order that is advertised to dimensionally fit a 240. Since I'll have to remove the A/C condenser to get to the radiator bolts, it's finally time to modify the install and weld some nuts to the support and run the bolts the OTHER WAY (from the radiator side) so removal is easy and the same as they did on the ZX.

So...... just another $200 here and another $200 there and this newer engine/EFI will hopefully be happy in a 240Z? :roll:
Last edited by TexasZX on Tue May 26, 2009 6:09 am, edited 2 times in total.

TexasZX
MegaSquirt Newbie
Posts: 9
Joined: Mon Apr 13, 2009 10:47 am

End of project

Post by TexasZX » Thu May 07, 2009 6:47 am

End of project
Installed radiator and temps are now correct. The Alternator swap already eliminated the flaky voltage spikes. The car is finally DONE. :yeah!:

It took about 6 months total time and roughly $4,400 to complete the engine and have it installed correctly.
That was twice as much time and money that I budgeted for a "simple" engine build and get it running right in the car.
Since you have to control both fuel and spark, I'd recommend the Megasquirt II like I used. DIY Autotune was a great source/resource. Even though the v3.57 is SMD pre-built and comes jumpered correctly for EDIS, just be aware that such a system is the complete opposite of plug-and-play! You WILL need to read a boatload of manuals (several times) to find out JUST HOW to make it work.

I'll quote from the MegaManual:
"MegaSquirt® and MicroSquirt® controllers are experimental devices intended for educational purposes. The MegaSquirt® family of EFI controllers is a series of experimental Do-It-Yourself universal programmable electronic fuel injection controllers for spark ignition, liquid fueled internal combustion engines. Experimental means that YOU will be responsible for sorting out some details of your fuel injection that are specific to your application and equipment"

KaPower
MegaSquirt Newbie
Posts: 3
Joined: Wed Dec 22, 2004 8:43 pm
Location: Tacoma

Re: 240Z Turbo swap (MSII, EDIS)

Post by KaPower » Thu May 07, 2009 6:19 pm

The thing about MegaSquirting a Car is that once you start a project, it never ends. There's always going to be that one more improvement that you want to make... always new code to try out... always something to fine tune...

Your "End of project" declaration reminds me of George Bush proclaiming Victory with a huge banner after landing in a fighter jet on that aircraft carrier.

Nice write up, keep us updated.

-JM

TexasZX
MegaSquirt Newbie
Posts: 9
Joined: Mon Apr 13, 2009 10:47 am

Re: 240Z Turbo swap (MSII, EDIS)

Post by TexasZX » Fri May 08, 2009 7:36 am

Thanks! But I do consider it the end of installing that "free" turbo engine.
Now that all the systems (intake, exhaust, ignition, fuel, cooling, electrical, transmission, dash gauges) have been adapted, I'm freed up to just do maintenance. Maintaining is 100 times easier than creating!

Right now, the 1983 hydraulic P90a head and turbo sliced exhaust is making lots of nearly silent power. Not only quiet but the new 5 speed does not even need to downshift when passing at freeway speeds. If you need a little more power, you just push the accelerator a bit more. I hate to say it but I kind of miss the "sports car" sounds form a header, the sports car downshifting and blipping the throttle in a turn, and the smells of raw gas to confirm anytime you accelerate hard. Even startup no longer requires pulling a choke lever and a quick blip on the accelerator pedal to get it the mixture just right. Now all you do is turn the key and leave the driving to the the ECU (just like a Camry).

Can MS EFI be the wrong choice when you don't modify your turbo engine above the 180-200hp stock HP?
I think that's why most installs I've read use monster injectors and big boost levels.
I don't have the time/money to rebuild the engine, driveline and other systems all over again.
Lots of work, everything works well, I learned a lot.
One lesson learned was that MSII was more work than an advantage when you use it to merely simulate a stock ECU.

TexasZX
MegaSquirt Newbie
Posts: 9
Joined: Mon Apr 13, 2009 10:47 am

6 Month Update

Post by TexasZX » Thu Aug 20, 2009 8:51 am

6 month update after adding an EFI/Turbo/EDIS/L28ET/5speed to a 240Z:
-The MSII 3.57 from DIY Autotune has worked flawlessly.
-The EDIS ignition has been flawless (after buying the new coil pack and module).
-The EFI injectors, resistor pack, home made fuel rail, '75 gas tank and Walbro pump are still working well.
-MegaTune becomes easier (Not from familiarity but simply because the initial setup takes such a massive bit of learning). Once it's setup then just making minor VE tweaks are really nothing.

-The added 280ZX internally regulated alternator gives rock solid output, a must for EFI.
-The change from NB-O2 to DIY Autotune LC1 WB02 is a must. I'm keeping the digital AFR gauge permanently mounted in the dash as a simple way to monitor the whole health of the fuel system at a glance. I'm running completely from VE tables(no O2 feedback) and it's been remarkably stable.

One new problem is developing:
The original R180 and half shaft bearings are beginning to let loose. I believe that the added power has accelerated the wear on these older driveline parts. This will be another area (like the heat shield) where Nissan did everyone a favor. I now find myself in the market for some 280ZX turbo CV half shafts and an R200 differential....

Post Reply