92 240SX KA24DE, MS2Extra, stock ignition

Nissan, Infiniti, Datsun
Post Reply
wheelman
MegaSquirt Newbie
Posts: 2
Joined: Thu Sep 15, 2005 3:44 pm
Location: South Eastern WA

92 240SX KA24DE, MS2Extra, stock ignition

Post by wheelman » Sat Dec 05, 2009 3:39 pm

It's not quite running but I'm getting signals from all the sensors.
As the subject line says it's a 1992 240SX KA24DE with a stock ignition (distributor and CAS), driving the coil with the VB921.
I get fuel and spark but the engine wants to kick back instead of start.

Before starting the install I set the timing at 20 degrees as the FSM states.
I've seen a couple posts talking about this problem with these engines but no solutions (at least I didn't see any).
I'm currently charging the battery in preparation to try again.
I'm thinking I may have the base timing in the software set wrong, the ignition wizard showed 0* advance when I pulled it up, is this because it doesn't read the base value from the contoller or is that what it's set at. I thought I preset it before starting the install but I might be mis-remembering.

Would retarding the timing at the distributor help to solve this problem?

Anyway, any help or advice with this would be appreciated. :)

BTW: Does anyone have a set of VE and ignition tables I could use as a starting point for tuning or an MSQ file for an MS-II running MS2Extra 2.1.0p?
The engine is currently NA but the plan is to install a T3 turbo once I have it running, which will be soon if things go as planned. The turbo install will probably wait for things to warm up a bit as my garage isn't heated. I've installed a set of 370cc injectors in preparation for the turbo.

seishuku
MegaSquirt Newbie
Posts: 33
Joined: Sat Nov 21, 2009 2:05 pm
Location: Wisconsin

Re: 92 240SX KA24DE, MS2Extra, stock ignition

Post by seishuku » Sat Dec 05, 2009 4:42 pm

Set the timing at the distributor at 5 degrees BTDC, then set the trigger angle to 5 degrees.
That's how mine is set right now, it does take a bit of time cranking to get it to fire and does want to kick sometimes.

wheelman
MegaSquirt Newbie
Posts: 2
Joined: Thu Sep 15, 2005 3:44 pm
Location: South Eastern WA

Re: 92 240SX KA24DE, MS2Extra, stock ignition

Post by wheelman » Thu Jan 07, 2010 11:18 pm

An update on my progress!

I've made several changes to get the engine running.
First, I determined the required value for the Trigger Angle/Offset is 80*. This placed my distributor in the center of it's adjustment range when the base timing is 20* advanced at idle. This was using Basic Triggering and Ignition Input Capture set to Falling Edge. At this point in the process I was using the tach input circuit from the DIYAUTOTUNE website which calls for a 12V pullup on the primary tach input line from the distributor. It connects to the Low-Res signal of the Nissan CAS.

Later I went to MSExtra.com and found a thread discussing decode support for the Nissan CAS wheels.
The code is alpha 3.0.3r and supports the RB, SR and KA CAS wheels.

After discussing my setup I changed the primary tach input circuit so it does not require a 12V pullup (the CAS is designed for 5V operations) and added another opto-isolated circuit for the secondary, Hi-Res, signal from the CAS. The circuits are basically the same as those used with a Mitsubishi 4G63 and Miata CAS.
Because these circuits invert the signal from the CAS the Input Capture must be set to Rising Edge. Version 3.0.3r adds 2 entries to the "Spark Mode" list that enable support for the the Nissan COP and distributor setups. When one of these is selected the Trigger Angle/Offset is hardcoded so the field on the form should be set to 0. It's also possible to enable or disable use of the hi-res signal when using the distributor setup. If the Hi-Res signal is enabled it is only used during low rpm operations.

Long story short, the engine fires right up with no kick back problems.
I performed a small amount of tuning just to get the engine to start and idle and played with the closed loop idle control of the Nissan PWM idle valve.
Now I'm working on installing the turbo.
As soon as I have more to report I'll post it up, in the mean time if anyone has questions about the changes I've made feel free to ask.

Wheelman (Ken Wheeler)

Post Reply